errors with different rspec runtimes

Just tried re-running a spec before adding some new functionality and ….

can't activate rspec (= 1.1.12, runtime), already activated rspec-1.2.0 (Gem::Exception)

Ok so I decided to remove the bad version that was complaining.

sudo gem uninstall rspec -v 1.1.12

Gah, another error.

RubyGem version error: rspec(1.1.4 not = 1.1.12) (Gem::LoadError)

Ok so it must be something to do with version mismatches and there are always 2 gems required for RSpec with Rails. I guess rspec-rails looks for the nearest matched version of rspec

rl@bloodandguts:~$ gem list | grep "rspec"
rspec (1.2.0, 1.1.11, 1.1.9, 1.1.4)
rspec-rails (1.1.12, 1.1.11, 1.1.9)

A new install of rspec-rails actually then fixed everything up nicely.

rl@bloodandguts:~$ sudo gem install rspec-rails
Successfully installed rspec-1.2.2
Successfully installed rspec-rails-1.2.2
2 gems installed